Bootstrap error

A place for Ventity software questions & answers
Post Reply
Phill
Senior Member
Posts: 95
Joined: Wed Jun 04, 2014 2:18 pm
Vensim version: DSS

Bootstrap error

Post by Phill » Mon Mar 13, 2017 2:04 pm

On trying to launch Ventity this morning I received the attached error. I can't get past that error message; it appears as soon as I click the Ventity icon, so I'm a bit stuck and I'd appreciate any help! I've come across the 'input string was not in a correct format' error before, but only in the context of web code, not an installed program.
Attachments
Bootstrap.PNG
Bootstrap.PNG (4.28 KiB) Viewed 2005 times

tomfid
Administrator
Posts: 2408
Joined: Wed May 24, 2006 4:54 am

Re: Bootstrap error

Post by tomfid » Mon Mar 13, 2017 5:02 pm

Are you running the latest version (1.0.1)?

Phill
Senior Member
Posts: 95
Joined: Wed Jun 04, 2014 2:18 pm
Vensim version: DSS

Re: Bootstrap error

Post by Phill » Mon Mar 13, 2017 9:23 pm

I think so; it's release date is 31st January.

Phill
Senior Member
Posts: 95
Joined: Wed Jun 04, 2014 2:18 pm
Vensim version: DSS

Re: Bootstrap error

Post by Phill » Tue Mar 14, 2017 11:36 am

You were right, thank you. I didn't realise I wasn't running the latest version, but downloading that and installing it cured my problem.

tomfid
Administrator
Posts: 2408
Joined: Wed May 24, 2006 4:54 am

Re: Bootstrap error

Post by tomfid » Tue Mar 14, 2017 12:18 pm

Great. 1.0.0 had that problem on some machines. We can't figure out what causes it, but fortunately we found a way to avoid it in 1.0.1. The releases were very close together, so it would have been easy to miss.

gsimpso4
Junior Member
Posts: 7
Joined: Thu Mar 09, 2017 9:37 am
Vensim version: Ventity

Re: Bootstrap error

Post by gsimpso4 » Fri Mar 17, 2017 10:45 am

I am having similar issues, corrupting work with no way to recover.

I find that when I download from the update page at http://ventity.biz/update/
I get a version dated 30 Jan 2017. The splash screen says I have version 1.0, although the zip file was labelled 1.01.

Is there another place I should be going?

I am running 64 bit on Windows Server 2008.

Will email my model files - see mail from GeorgeSimpson1@tfl.gov.uk

...george...

gsimpso4
Junior Member
Posts: 7
Joined: Thu Mar 09, 2017 9:37 am
Vensim version: Ventity

Re: Bootstrap error

Post by gsimpso4 » Fri Mar 17, 2017 2:37 pm

Finding stability as long as I don't import entities and then rename the entity type. Maybe that was the issue. Fingers crossed!

tomfid
Administrator
Posts: 2408
Joined: Wed May 24, 2006 4:54 am

Re: Bootstrap error

Post by tomfid » Sat Mar 18, 2017 7:36 pm

Do you know what your exact sequence is? I can open a model, import an entitytype from another model, rename it to "Fred," save & close the model, then reopen successfully. I must be missing a step in there somewhere.

LarryYeager
Junior Member
Posts: 4
Joined: Fri Oct 14, 2016 12:43 am
Vensim version: Ventity

Re: Bootstrap error

Post by LarryYeager » Sun Mar 19, 2017 2:05 am

The problem was a rename that missed the on chart diagrams (the bug that allowed that may have already been fixed in the development copy). Fixed file attached.

Sorry about that!
Attachments
Model 9.zip
(14.88 KiB) Downloaded 46 times

Jeraldine Jent
Junior Member
Posts: 2
Joined: Wed Mar 22, 2017 4:06 pm
Vensim version: PLE

Re: Bootstrap error

Post by Jeraldine Jent » Wed Mar 22, 2017 4:19 pm

LarryYeager wrote:The problem was a rename that missed the on chart diagrams (the bug that allowed that may have already been fixed in the development copy). Fixed file attached.

Sorry about that!

I have the same problem, but it does not help. Are there other ways ?
Last edited by Jeraldine Jent on Fri Mar 24, 2017 4:47 pm, edited 1 time in total.

tomfid
Administrator
Posts: 2408
Joined: Wed May 24, 2006 4:54 am

Re: Bootstrap error

Post by tomfid » Wed Mar 22, 2017 4:58 pm

Can you send us the file? We should be able to repair it. Post or email is fine. Version 1.0.2 (next few days) will fix this permanently.

Jeraldine Jent
Junior Member
Posts: 2
Joined: Wed Mar 22, 2017 4:06 pm
Vensim version: PLE

Re: Bootstrap error

Post by Jeraldine Jent » Fri Mar 24, 2017 4:55 pm

tomfid wrote:Can you send us the file? We should be able to repair it. Post or email is fine. Version 1.0.2 (next few days) will fix this permanently.
Thanks, but colleagues at work have already solved this problem :D

Post Reply