Optimisation

A place for Ventity software questions & answers
Post Reply
Lubo
Junior Member
Posts: 5
Joined: Mon Oct 14, 2013 1:38 pm
Vensim version: PLE

Optimisation

Post by Lubo »

Hi

I have tried to test the optimisation function in a simple inventory management model. The model calculates a profit based on revenues and cost based on an item's purchase and storage cost.
I want to identify the optimal “inventory coverage” while maximising the profit. Following is a list of problems I have encountered:
1. In the optimisation dialogue box I add a “new optimisation”. Then I add a new payoff and select “Profit” from the drop down menu. Then I click on the “Parameters” and want to add Inventory coverage as the parameter to be optimised. The drop down list does not appear to be working and the only variable available is “Delivery Delay”, probably because it is on the top of the list of variables for the given entity. Not sure what I am doing wrong. I have tried a few different things but do not get correct results even I managed to run optimisation.
2. How would I use optimisation if instead of maximising goal I would want to minimise cost or stockouts?
3. Wanted to use DelayInformation for supplies as a “material delay” function but it does not produce expected results. I tried the function in a different model and it was working fine as a material delay function where results would be identical to inputs after the delay. Not sure what has changed in this model

A few other errors I have encountered:
1. In the attached pdf file page 1 and 2 – am not able to run two models which come with Ventity - GIS and Wilshire fund – not sure if it is my laptop security setup or something else related to file paths in the models. Ventity error file attached.
2. When I want to select DelayInformation function when in the variable defining dialogue box and use either double click or enter I get an error message and have to type DelayInformation - pages 3 and 4 in the same file.

As always, thank you very much for your help. And Happy Easter!

Lubo
Attachments
Ventity error file.pdf
(241.75 KiB) Downloaded 42 times
Optimisation3.zip
(11.22 KiB) Downloaded 41 times
Error messages.pdf
(647.6 KiB) Downloaded 40 times
tomfid
Administrator
Posts: 3259
Joined: Wed May 24, 2006 4:54 am

Re: Optimisation

Post by tomfid »

1. One issue is that you need to check the "Constant" box on the Inventory Coverage variable to make it available as a parameter.
2. If you want to minimize, you can give the payoff element a negative weight.
3. Grab the latest v4.5 (just out) - there was an issue with DelayInformation in 4.4. DelayInformation behaves like a material pipeline delay as long as the delay time doesn't change (we don't currently have the material equivalent, so ping us if you need the variable delay time).
Lubo
Junior Member
Posts: 5
Joined: Mon Oct 14, 2013 1:38 pm
Vensim version: PLE

Re: Optimisation

Post by Lubo »

Hi

I have installed 4.5 and it appears the DelayInformation function is working fine now and optimisation definition screens work better. I am still not able to run GIS and Wilshire models since I am getting the same error.

1. Is there a place where one can define number of iterations in optimisation or a desired level of accuracy? When does the optimiser consider it has found the optimal result?
2. Is there any documentation how optimizer finds the optimal result when there is more than one payoff? In Optimisation 2 I tried to maximise Profit with +50% weighting and minimising Stockouts with -50% weighting but am not sure how to interpret the results.

Thanks
Lubo
Attachments
Optimisation4.zip
(10.75 KiB) Downloaded 27 times
tomfid
Administrator
Posts: 3259
Joined: Wed May 24, 2006 4:54 am

Re: Optimisation

Post by tomfid »

I'll take a look at the remaining issues.

When there are multiple payoff elements, the optimizer maximizes the sum of the variables, multiplied by the weights.
tomfid
Administrator
Posts: 3259
Joined: Wed May 24, 2006 4:54 am

Re: Optimisation

Post by tomfid »

The Wilshire model is working fine for me. What error are you seeing?
tomfid
Administrator
Posts: 3259
Joined: Wed May 24, 2006 4:54 am

Re: Optimisation

Post by tomfid »

ventityOptSettings.png
ventityOptSettings.png (19.39 KiB) Viewed 449 times
There are some optimization control settings in the payoff dialog. Normally the Fractional Tolerance is the most productive to play with for controlling run length and precision of the result.
tomfid
Administrator
Posts: 3259
Joined: Wed May 24, 2006 4:54 am

Re: Optimisation

Post by tomfid »

If you're seeing this, it might be a path permission issue.
2021-04-26_12-51-27.png
2021-04-26_12-51-27.png (10.06 KiB) Viewed 449 times
There are two copies of the Ventity samples installed. You might try the one in your local user documents folder, rather than users\public. If that also fails, perhaps copy/paste the model directory to an unlocked location.
Lubo
Junior Member
Posts: 5
Joined: Mon Oct 14, 2013 1:38 pm
Vensim version: PLE

Re: Optimisation

Post by Lubo »

Switching to Ventity files installed in "user" document folder allowed me to run the models. And fractional tolerance increased optimal result accuracy. Thank you for your answers, problems solved.
Post Reply